Tuesday, April 29, 2008

EIGRP Auto Summarization

EIGRP Auto Summarization

Router(config-router)#no auto-summary

Turns off the auto-summarization feature. Networks are summarized at the classful boundary by default

Router(config)#int fa 0/0

Router(config-if)ip summary-address eigrp 100 10.10.0.0 255.255.0.0

Enables manual summarization on this specific interface for the given address and mask


Caution:

EIGRP automatically summarizes networks at the classful boundary. A poorly designed network with discontiguous subnets could have problems with connectivity if the summarization feature is left on. You could have two routers advertise the same network172.16.0.0/16when in fact the intention is for the routers to advertise two different networks172.16.10.0/24 and 172.16.20.0/24.

Recommended practice is that you turn off automatic summarization, use the ip summary-address command, and summarize manually what you need to.

Wednesday, April 23, 2008

Configuring EIGRP

Configuring EIGRP

Router(config)#router eigrp 100

Turns on the EIGRP process

100 is the autonomous system (AS) number, which can be a number between 1 and 65535

All routers in the same AS must use the same AS number

Router(config-router)#network 10.0.0.0

Specifies which network to advertise in EIGRP

Router(config-router)#eigrp log-neighbor-changes

Logs any changes to an EIGRP neighbor adjacency


Tip:

The eigrp log-neighbor-changes command, although optional, is recommended to help with troubleshooting.


Router(config-router)#no network 10.0.0.0

Removes the network from the EIGRP process

Router(config)#no eigrp 100

Disables routing process 100

Router(config-if)#bandwidth x

Sets the bandwidth of this interface to x kilobits to allow EIGRP to make a better routing decision


Tip:

The bandwidth command is used for metric calculations only. It does not change interface performance.

Monday, April 21, 2008

Configuration Example: RIP Ver 2 Routing

Configuration Example: RIP-2 Routing

Figure A shows the network topology for the configuration that follows, which shows how to configure RIP-2 using the commands covered in this chapter.

Figure 8-1. Network Topology for RIP-2 Routing Configuration













Boston Router

Boston>en

Boston#config t

Boston(config)#router rip

Enables RIP routing

Boston(config-router)#version 2

Enables RIP-2

Boston(config-router)#network 172.16.0.0

Advertises directly connected networks (classful address only)

Boston(config-router)#no auto-summary

Turns off autosummarization

Boston(config-router)#exit

Boston(config)#exit

Boston#copy run start


Buffalo Router

Buffalo>en

Buffalo#config t

Buffalo(config)#router rip

Enables RIP routing

Buffalo(config-router)#version 2

Enables RIP-2

Buffalo(config-router)#network 172.16.0.0

Advertises directly connected networks (classful address only)

Buffalo(config-router)#no auto-summary

Turns off autosummarization

Buffalo(config-router)#Cntl+z

Exits back to privileged mode

Buffalo#copy run start


Bangor Router

Bangor>en

Bangor#config t

Bangor(config)#router rip

Enables RIP routing

Bangor(config-router)#version 2

Enables RIP-2

Bangor(config-router)#network 172.16.0.0

Advertises directly connected networks (classful address only)

Bangor(config-router)#no auto-summary

Turns off autosummarization

Bangor(config-router)#Cntl+z

Exits back to privileged mode

Bangor#copy run start


Sunday, April 20, 2008

RIP Version 2: Optional Commands

RIP Version 2: Optional Commands

Router(config-router)#no version 2

Changes back to RIP-1

Router(config-router)#version 1

Changes RIP routing to RIP-1

Router(config-router)#no auto-summary

RIP-2 summarizes networks at the classful boundary. This command turns autosummarization off

Router(config-router)#auto-summary

Re-enables autosummarization at the classful boundary


Thursday, April 17, 2008

RIP Version 2: Mandatory Commands Networking How-to

RIP Version 2: Mandatory Commands


Router(config)#router rip

Turns on the RIP routing process; the same command as used for RIP Version 1 (RIP-1)


Router(config-router)#version 2

Turns on Version 2 of the routing process. Version 1 is default


Router(config-router)#network w.x.y.z

w.x.y.z is the network number of the directly connected classful network you want to advertise


Wednesday, April 16, 2008

Troubleshooting RIP Networking How-to

Troubleshooting RIP Issues

Router#debug ip rip

Displays all RIP activity in real time

Router#show ip rip database

Displays contents of the RIP database


Tuesday, April 15, 2008

RIP Version 2 Networking How-to

RIP Version 2

Note:

RIP-2 is not currently part of the CCNA certification exam. Commands are listed here for reference only.


Router(config-router)#version 2

RIP will now send and receive RIP-2 packets globally

Router(config-if)#ip rip send version 1

Interface will send only RIP-1 packets

Router(config-if)#ip rip send version 2

Interface will send only RIP-2 packets

Router(config-if)#ip rip send version 1 2

Interface will send both RIP-1 and RIP-2 packets

Router(config-if)#ip rip receive version 1

Interface will receive only RIP-1 packets

Router(config-if)#ip rip receive version 2

Interface will receive only RIP-2 packets

Router(config-if)#ip rip receive version 1 2

Interface will receive both RIP-1 and RIP-2 packets


Monday, April 14, 2008

RIP Routing: Optional Commands Networking How-to


RIP Routing: Optional Commands

Router(config)#no router rip

Turns off the RIP routing process

Router(config-router)#no network w.x.y.z

Removes network w.x.y.z from the RIP routing process

Router(config-router)#passive-interface s0/0

RIP updates will not be sent out this interface

Router(config-router)#neighbor a.b.c.d

Defines a specific neighbor with which to exchange information

Router(config-router)#no ip split-horizon

Turns off split horizon (on by default)

Router(config-router)#ip split-horizon

Re-enables split horizon

Router(config-router#timers basic 30 90 180 270 360

Changes timers in RIP:

30 = Update timer (in seconds)

90 = Invalid timer (in seconds)

180 = Hold-down timer (in seconds)

270 = Flush timer (in seconds)

360 = Sleep time (in milliseconds)

Router(config-router)#maximum-paths x

Limits the number of paths for load balancing to x (4 = default, 6 = maximum)

Router(config-router)#default-information originate

Generates a default route into RIP


RIP Routing: Mandatory Commands Networking How-to

RIP Routing: Mandatory Commands

Router(config)#router rip

Enables RIP as a routing protocol

Router(config-router)#network w.x.y.z

w.x.y.z is the network number of the directly connected network you want to advertise


Note:

You need to advertise only the classful network number, not a subnet:

Router(config-router)#network 172.16.0.0 

not

Router(config-router)#network 172.16.10.0 

If you advertise a subnet, you will not receive an error message, because the router will automatically convert the subnet to the classful network address.

Thursday, April 10, 2008

IP Classless Command Networking How-to

IP Classless

Router(config)#ip classless

Instructs IOS to forward packets destined for an unknown subnet to the best supernet route


Router(config)#no ip classless

Turns off the ip classless command


Note:
A supernet route is a route that covers a range of subnets with a single entry.


Note:
The ip classless command is enabled by default in Cisco IOS Software Release 11.3 and later.


Wednesday, April 9, 2008

Verifying Static Routes Networking How-to

Verifying Static Routes


Router#show ip route --------> Displays contents of IP routing table


Note:

The codes to the left of the routes in the table tell you from where the router learned the routes. A static route is described by the letter S.

Tuesday, April 8, 2008

Routing: Default Routing Networking How-to

Default Routing

Router(config)#ip route 0.0.0.0 0.0.0.0 172.16.10.2

Send all packets destined for networks not in my routing table to 172.16.10.2

Router(config)#ip route 0.0.0.0 0.0.0.0 s0/0

Send all packets destined for networks not in my routing table out my Serial 0/0 interface


Monday, April 7, 2008

Routing: Static Routing Networking How-to

Static Routing

When using the ip route command, you can identify where packets should be routed to in two ways:

  • The next-hop address

  • The exit interface


Router(config)#ip route 172.16.20.0 255.255.255.0 172.16.10.2

172.16.20.0 = destination network


255.255.255.0 = subnet mask


172.16.10.2 = next-hop address


Read this to say: To get to the destination network of 172.16.20.0, with a subnet mask of 255.255.255.0, send all packets to 172.16.10.2

Router(config)#ip route 172.16.20.0 255.255.255.0 s0/0

172.16.20.0 = destination network


255.255.255.0 = subnet mask


s0/0 = exit interface


Read this to say: To get to the destination network of 172.16.20.0, with a subnet mask of 255.255.255.0, send all packets out interface Serial 0/0


The permanent Keyword (Optional)

Router(config)#ip route 172.16.20.0 255.255.255.0 172.16.10.2 permanent

Specifies that the route will not be removed, even if the interface shuts down


Without the permanent keyword in a static route statement, a static route will be removed if an interface goes down. If you don't tighten those serial cables or if you have a bad connector on a UTP cable, a cable can easily become loose, causing an interface to go down. But plugging the cable back in does not add that static route back into the routing table. The only way to get that route back into the table is to reload the router or use the permanent keyword in your ip route command. This option is especially useful when the night janitor knocks a cable loose and replaces it, hoping no one will notice. Can your network afford to lose a route for a few hours until the next morning when you or your IT staff comes in to work? The permanent keyword is also useful in helping to avoid constant shortest path first (SPF) calculations in OSPF when there is a flapping link; if the link goes down, the route will stay in the routing table.

However, you must be careful when using this optional keyword. You might want that route to be removed from the routing table. You might also want to know why the night janitor was in your wiring closet in the first place.

Static Routes and Administrative Distance (Optional)

Router(config)#ip route 172.16.20.0 255.255.255.0 172.16.10.2 200

Specifies that an administrative distance of 200 has been assigned to this route.


Note:

By default, a static route is assigned an administrative distance (AD) of 1. Administrative distance rates the "trustworthiness" of a route. AD is a number from 0-255, where 0 is absolutely trusted, and 255 cannot be trusted at all. Therefore, an AD of 1 is an extremely reliable rating, with only an AD of 0 being better. An AD of 0 is assigned to a directly connected route. The following table lists the administrative distance for each type of route.


Route Type

Administrative Distance

Connected

0

Static

1

EIGRP Summary Route

5

EBGP

20

EIGRP (Internal)

90

IGRP

100

OSPF

110

IS-IS

115

RIP

120

EGP

140

On-Demand Routing

160

EIGRP (External)

170

iBGP (External)

200

Unknown

255


Tip:

By default, a static route will always be used instead of a routing protocol. By adding an AD number to your ip route statement, however, you can effectively create a backup route to your routing protocol. If your network is using EIGRP, and you need a backup route, add a static route with an AD greater than 90. EIGRP will be used because its AD is better (lower) than the static route. But if EIGRP goes down, the static route will be used in its place. This is known as a floating static route.

Thursday, April 3, 2008

Configuration Example: Basic Router Configuration


Figure A shows the network topology for the configuration that follows, which shows a basic router configuration using the commands covered in this chapter.

Figure A. Network Topology for Basic Router Configuration






Boston Router

Router>en

Enters privileged mode

Router#clock set 18:30:00 15 Nov 2004

Sets local time on router

Router#config t

Enters global config mode

Router(config)#hostname Boston

Sets router name to Boston

Boston(config)#no ip domain-lookup

Turns off name resolution on unrecognized commands (spelling mistakes)

Boston(config)#banner motd #

Creates an MOTD banner

This is the Boston Router.


Authorized Access Only


#


Boston(config)#clock timezone EST 5

Sets time zone to Eastern Standard Time (5 from UTC)

Boston(config)#enable secret cisco

Enables secret password set to cisco

Boston(config)#service password-encryption

Passwords will be given weak encryption

Boston(config)#line con 0

Enters line console mode

Boston(config-line)#logging sync

Commands will not be interrupted by unsolicited messages

Boston(config-line)#password class

Sets password to class

Boston(config-line)#login

Enables password checking at login

Boston(config-line)#line vty 0 4

Moves to virtual Telnet lines 0 through 4

Boston(config-line)#password class

Sets password to class

Boston(config-line)#login

Enables password checking at login

Boston(config-line)#line aux 0

Moves to line auxiliary mode

Boston(config-line)#password class

Sets password to class

Boston(config-line)#login

Enables password checking at login

Boston(config-line)#exit

Moves back to global config mode

Boston(config)#no service password-encryption

Turns off password encryption

Boston(config)#int fa 0/0

Moves to Fast Ethernet 0/0 mode

Boston(config-if)#desc Engineering LAN

Sets locally significant description of the interface

Boston(config-if)#ip address 172.16.10.1 255.255.255.0

Assigns IP address and subnet mask to the interface

Boston(config-if)#no shut

Turns on the interface

Boston(config-if)#int s0/0

Moves directly to Serial 0/0 mode

Boston(config-if)#desc Link to Buffalo Router

Sets locally significant description of the interface

Boston(config-if)#ip address 172.16.20.1 255.255.255.0

Assigns IP address and subnet mask to the interface

Boston(config-if)#clock rate 56000

Sets a clock rate for serial transmission. DCE cable must be plugged into this interface

Boston(config-if)#no shut

Turns on the interface

Boston(config-if)#exit

Moves back to global config mode

Boston(config)#ip host buffalo 172.16.20.2

Sets a local host name resolution to IP address 172.16.20.2

Boston(config)#exit

Moves back to privileged mode

Boston#copy run start

Saves running-config to NVRAM



Wednesday, April 2, 2008

Erasing Configurations - Networking How-to

Erasing Configurations

Router#erase start

Deletes the startup-config file from NVRAM


Tip:

Running-config is still in dynamic memory. Reload the router to clear the running-config.

Tuesday, April 1, 2008

Saving Configurations - Networking How-to

Saving Configurations

Router#copy run start

Saves the running-config to local NVRAM

Router#copy run tftp

Saves the running-config remotely to TFTP server

exec-timeout Command - Networking How-to

exec-timeout Command

Router(config)#line con 0


Router(config-line)#exec-timeout 0 0

Sets time limit when console automatically logs off. Set to 0 0 (minutes seconds) means console never logs off

Router(config-line)#



Tip:

exec-timeout 0 0 is great for a lab because the console never logs out. This bad security is very dangerous in the real world.